Our site uses cookies to improve your browsing experience. To learn more please read our Privacy Policy
RSS Feed

Help with Java plugin issues

Fronter includes a few Java plugins, most notably the download application and the sound recorder. These applications are not required for login to Fronter so they are optional in that sense and not having them enabled does not impede using other Fronter functionality. See also here about the future of Java and related plugins.

Issues with launching the Java applets

We occasionally receive reports of browser specific Java issues.

Usually these issues have been resolved through ensuring the latest Java RTE is installed, and all old Java RTE versions removed. This is also highly recommended by Oracle. As Oracle, we also recommend always running the latest Java RTE.

Message about expired or insecure jre

In some cases when logging into Fronter, you may see a pop-up message with the heading "Application blocked by security settings". This error message is displayed by your browser advising you effectively to upgrade the Java you have on your local system. Once you upgrade your Java, you may then upon login get an additional prompt asking if the Fronter site should be allowed to launch a Java applet.

Mac OS X users

To run Java 7 and later, you will need an Intel-based Mac running Mac OS X version 10.7.3 (Lion) and above. Further, a 64-bit browser (Safari, Firefox for example) is required to run Oracle Java on Mac OS X. Chrome 64-bit for Mac is in beta. Please see here for more information (java.com).

More information

Please see the links below for more information and guides related to Java: